
Wireshark دليل شامل لأداة
الجزء الثاني

مرحباً بك في الدليل المتقدم لأداة Wireshark، حيث ستتعلم تقنيات التحليل المتقدمة، الأوامر
الكاملة، والأسرار التي تجعلك خبيراً في تحليل حركة الشبكة.


من إعداد: أ. عبد الصمد بوركيبات

باحث في فقه الأمن السيبراني الأسري، ومتخصص في الأمن السيبراني


أوامر كاملة

فلاتر متقدمة، أوامر خطية، واختصارات لتحليل
فعال


تحليل أمني

كشف الهجمات، تحليل التهديدات، وحماية
الشبكات


رسوم بيانية

تصورات متقدمة، تحليلات مرئية، وتقارير تفصيلية


مهام عملية

تمارين واقعية، سيناريوهات تطبيقية، وحالات
دراسية


تحليل متقدم

بروتوكولات معقدة، حركة مشفرة، واستكشاف
أخطاء


أسرار احترافية

نصائح الخبراء، تقنيات متقدمة، وأفضل
الممارسات



مرجع أوامر Wireshark الشامل
فلاتر الالتقاط، فلاتر العرض، العوامل المنطقية، واختصارات لوحة المفاتيح

filter_altفلاتر الالتقاط

مثالالنوع

IP عنوانhost 192.168.1.1

TCP/UDP منفذtcp port 80

IP نطاقnet 192.168.1.0/24

tcp or udpبروتوكول

MAC عنوانether host 00:0c:29:12:34:56

filter_listفلاتر العرض

مثالالنوع

IP عنوانip.addr == 192.168.1.1

ip.src == 192.168.1.1عنوان المصدر

ip.dst == 192.168.1.1عنوان الوجهة

tcp.port == 80المنفذ

tcp or httpالبروتوكول

codeالعوامل المنطقية والمقارنة

مثالالوصفالعامل

and
منطقي

AND
ip.addr == 192.168.1.1 and

tcp.port == 80

orOR منطقيtcp.port == 80 or tcp.port ==
443

ip.addr == 192.168.1.1يساوي==

ip.addr != 192.168.1.1لا يساوي!=

keyboardاختصارات لوحة المفاتيح

play_arrowبدء/إيقاف الالتقاط - Ctrl+Efilter_altالبحث في الحزم - Ctrl+F

arrow_downwardالحزمة التالية - ↓+Ctrlarrow_upwardالحزمة السابقة - ↑+Ctrl

colorizeتلوين الحزم - Ctrl+Shift+Csaveحفظ الالتقاط - Ctrl+Sopen_in_newفتح ملف - Ctrl+O

find_in_pageالانتقال إلى الحزمة - Ctrl+N

نصيحة:
TCP لعرض جميع الحزم غير tcp! ! للنفي في فلاتر العرض، مثال:  استخدم 



تقنيات التحليل المتقدمة
متابعة تدفقات البروتوكول، تحليل TCP، إعادة تجميع الحزم، وتحليل المعلومات الخبيرة

streamمتابعة تدفقات البروتوكول

check_circleالكاملة TCP تحليل اتصالات :TCP Stream

check_circleHTTP عرض طلبات وردود :HTTP Stream

check_circleفك تشفير الجلسات المشفرة :SSL/TLS

check_circleUDP تحليل تدفقات :UDP Stream

lightbulbنصيحة

استخدم Analyze → Follow → TCP Stream لعرض محادثة TCP كاملة

analyticsوإعادة التجميع TCP تحليل

check_circleSYN، ACK، FIN، RST تحليل :TCP Flags

check_circleتتبع أرقام التسلسل والتأكيد :Sequence/Ack

check_circleكشف إعادة الإرسال :Retransmission

check_circleتحليل حجم النافذة :Window Size

lightbulbنصيحة

تفعيل TCP Analysis من Analyze → Expert Info لكشف المشاكل

merge_typeتقنيات إعادة تجميع الحزم

check_circleIP إعادة تجميع أجزاء :IP Defragmentation

check_circleTCP إعادة تجميع شرائح :TCP Reassembly

check_circleSMB إعادة تجميع ملفات :SMB Reassembly

check_circleHTTP استخراج كائنات :HTTP Objects

lightbulbنصيحة

استخدم File → Export Objects → HTTP... لاستخراج الملفات

psychologyتحليل المعلومات الخبيرة

check_circleعرض المشاكل والتحذيرات :Expert Info

check_circleتلوين الحزم حسب الأهمية :Colorization

check_circleإضافة ملاحظات للحزم :Notes

check_circleإضافة تعليقات للتحليل :Comments

lightbulbنصيحة

تفعيل View → Coloring Rules لتخصيص ألوان الحزم



Wireshark تحليل الأمان مع
SSL/TLS تحليل البرامج الضارة، وفك تشفير جلسات ،ARP كشف عمليات المسح، هجمات

radarNmap كشف عمليات مسح

check_circleإكمال المصافحة الثلاثية :TCP Connect

check_circleدون إكمال المصافحة SYN إرسال حزم :SYN Scan

check_circleICMP فحص المنافذ المغلقة عبر رسائل :UDP Scan

check_circleخصائص: حجم النافذة، أنماط الحزم، التوقيت

filter_altTCP Connect فلتر كشف

tcp.flags.syn == 1 and tcp.flags.ack == 0

securityMITM و ARP كشف هجمات

check_circleMAC تزوير عناوين :ARP Poisoning

check_circleمكررة ARP استجابات :Duplicate ARP

check_circleغير مطلوبة ARP حزم :gratuitous ARP

check_circleاعتراض وتحويل حركة المرور :MITM

filter_altغير طبيعي ARP فلتر كشف

arp.duplicate-address-detected

bug_reportتحليل سلوك البرامج الضارة

check_circleاتصالات منتظمة بخوادم التحكم :Beaconing

check_circleلتمرير البيانات DNS استخدام :DNS Tunneling

check_circleحركة مرور غير معتادة :Anomalous Traffic

check_circleتسريب البيانات :Exfiltration

filter_altفلتر كشف الاتصالات المنتظمة

frame.time_delta > 10 && frame.time_delta < 60

lock_openSSL/TLS فك تشفير جلسات

check_circleاستخدام مفتاح الخادم الخاص :Server Key

check_circleمتغير البيئة للمتصفحات :SSLKEYLOGFILE

check_circleتسجيل مفاتيح الجلسة :Pre-Master Secret

check_circleعرض البيانات المشفرة :Decrypted Traffic

filter_altلفك التشفير Wireshark إعداد

Edit → Preferences → Protocols → SSL → (Pre)-
Master-Secret log filename



التحليل البصري والرسوم البيانية
رسوم الحزم، رسوم I/O، خرائط GeoIP، وتصور هرميات البروتوكول

schema)Packet Diagrams( رسوم الحزم

check_circleعرض مرئي: تمثيل بصري للحزم والحقول

check_circleتفاعلي: النقر على العناصر لتمييزها

check_circleعرض القيم: إظهار قيم الحقول

check_circleفلاتر: عرض فلتر عند التمرير

lightbulbتفعيل الميزة

Edit → Preferences → Layout → Packet Diagram

show_chartلتحليل حركة المرور I/O رسوم

check_circleرسوم بيانية: تمثيل حركة المرور عبر الزمن

check_circleفلاتر متقدمة: تطبيق فلاتر على الرسوم

check_circleمقارنة: مقارنة بروتوكولات متعددة

check_circleتصدير: حفظ الرسوم للتحليل

lightbulbالوصول للميزة

Statistics → I/O Graph

publicGeoIP خرائط

check_circleتحديد الموقع: تحديد المواقع الجغرافية

check_circleفلترة: فلترة حسب الدولة/المنطقة

check_circleتحديد أرقام أنظمة المستقل :ASN

check_circleMaxmind GeoLite قواعد البيانات: استخدام

lightbulbفلترة حسب الموقع

ip and not ip.geoip.asnum == 63949

account_treeتصور هرميات البروتوكول

check_circleعرض طبقات الشبكة :OSI هرم

check_circleتسلسل: عرض تسلسل البروتوكولات

check_circleتحليل: تحليل العلاقات بين البروتوكولات

check_circleإحصائيات: إحصائيات البروتوكولات

lightbulbعرض إحصائيات البروتوكول

Statistics → Protocol Hierarchy



المهام والتمارين العملية
تمارين تحليل خطوة بخطوة، سيناريوهات واقعية، استكشاف أخطاء الشبكة، ودراسات حالة للتحقيقات الأمنية

assignmentتمارين تحليل خطوة بخطوة

looks_oneالتقاط الحزم: تحديد واجهة الشبكة وتطبيق الفلاتر

looks_twoTCP/UDP/HTTP تحليل البروتوكول: فحص حزم

looks_3Follow TCP Stream متابعة التدفقات: استخدام

looks_4استخراج البيانات: تصدير الكائنات من الحزم

tips_and_updatesمهمة عملية

Follow TCP وقم بتحليل الطلبات والردود باستخدام HTTP التقط حركة مرور
Stream

publicسيناريوهات واقعية

check_circleبطء الشبكة: تحديد أسباب التأخير

check_circleانقطاع الاتصال: تحليل فقدان الحزم

check_circleتطبيقات بطيئة: تشخيص مشاكل التطبيقات

check_circleازدحام الشبكة: تحديد مصادر الازدحام

tips_and_updatesمهمة عملية

حلل ملف PCAP يحتوي على مشكلة بطء في التصفح وحدد السبب

buildاستكشاف أخطاء الشبكة

check_circleDNS تحليل استعلامات :DNS مشاكل

check_circleتتبع عملية تخصيص العناوين :DHCP مشاكل

check_circleTCP Retransmission إعادة الإرسال: تحليل

check_circleMAC كشف تضارب عناوين :ARP مشاكل

tips_and_updatesمهمة عملية

استخدم Wireshark لتشخيص مشكلة في اتصال جهاز بالشبكة

securityدراسات حالة للتحقيقات الأمنية

check_circleتحليل هجمات الرجل في المنتصف :MITM هجوم

check_circleبرامج ضارة: كشف سلوك البرامج الخبيثة

check_circleمسح الشبكة: تحديد عمليات المسح غير المصرح بها

check_circleتسريب البيانات: تحليل محاولات استخراج البيانات

tips_and_updatesمهمة عملية

حلل ملف PCAP يحتوي على هجوم ARP Poisoning وحدد الجهاز المهاجم



قضية عملية 1: تحليل أداء الشبكة
تحديد أسباب بطء الشبكة وتحليل زمن الاستجابة وتحديد نقاط الازدحام

خطوات التحليل

التقاط البيانات: بدء التقاط حركة المرور على الواجهة المعنية

تطبيق الفلاتر: استخدام فلاتر لعزل حركة المرور ذات الصلة

مراقبة أنماط حركة المرور عبر الزمن :I/O Graph تحليل

فحص الحزم: تحليل الحزم ذات زمن الاستجابة المرتفع

تحديد المشاكل: البحث عن إعادة الإرسال وفقدان الحزم

الأدوات والفلاتر المستخدمة

فلتر زمن الاستجابة

frame.time_delta > 0.1

فلتر إعادة الإرسال

tcp.analysis.retransmission

فلتر فقدان الحزم

tcp.analysis.lost_segment

أداة إحصائيات نقطة النهاية

Statistics → Endpoints → IPv4

I/O أداة رسوم

Statistics → I/O Graph

النتائج والتوصيات

تحديد نقاط الازدحام: تحديد الأجهزة أو الروابط المسببة للازدحام

تحليل زمن الاستجابة: حساب متوسط زمن الاستجابة للشبكة

تحديد الأسباب: تحديد ما إذا كان البطء بسبب الأجهزة أو البرمجيات

توصيات التحسين: اقتراح حلول لتحسين أداء الشبكة

مستوى إكمال التحليل: %75

مهمة عملية

قم بتحميل ملف التقاط شبكة يحتوي على :PCAP تحميل ملف
مشكلة أداء

تحليل الحزم: استخدم الفلاتر لتحديد الحزم ذات المشاكل

لتمثيل حركة المرور I/O Graph إنشاء رسوم بيانية: استخدم

تقرير النتائج: قم بإعداد تقرير يلخص النتائج والتوصيات



قضية عملية 2: كشف هجمات الشبكة
استخدام Wireshark للكشف عن هجمات DDoS ومحاولات الاختراق وأنماط الحركة المشبوهة

أنواع الهجمات المشتركة

DDoSMan-in-the-MiddlePort Scanning

Brute ForceMalwareSQL Injection

فيضان الحزم من مصادر متعددة :DDoS هجمات

اعتراض وتعديل البيانات أثناء النقل :MITM

فحص المنافذ المفتوحة بحثاً عن ثغرات :Port Scanning

محاولات دخول متكررة بكلمات مرور مختلفة :Brute Force

فلاتر الكشف عن الهجمات

DDoS كشف هجمات

ip.src==192.168.1.1 && frame.time_delta < 0.01

كشف عمليات المسح

tcp.flags.syn==1 && tcp.flags.ack==0

كشف محاولات الدخول الفاشلة

ftp.response.code == 530 ||
ssh.connection.auth_failure

ARP Spoofing كشف هجمات

arp.duplicate-address-detected

كشف أنشطة البرامج الضارة

"dns.qry.name matches "(malicious|suspicious)

تحليل أنماط الهجمات

تحديد زيادة غير طبيعية في حركة المرور :I/O رسوم

تحديد مصادر الهجمات الجغرافية :GeoIP

تحليل التوقيت: تحديد أنماط تكرار الهجمات

تحليل البروتوكول: تحديد البروتوكولات المستهدفة

مستوى إكمال التحليل: %65

مهمة عملية

قم بتحميل ملف التقاط شبكة يحتوي على هجوم :PCAP تحميل ملف

تحليل الحزم: استخدم الفلاتر لتحديد نوع الهجوم

لتحليل نمط الهجوم I/O Graph إنشاء رسوم بيانية: استخدم

تقرير النتائج: قم بإعداد تقرير يحدد نوع الهجوم ومصدره



قضية عملية 3: تحليل بروتوكولات الشبكة
دراسة متعمقة لبروتوكولات TCP/IP و HTTP/DNS وتحليل سلوكها في ظروف مختلفة

بروتوكولات الشبكة الرئيسية

TCPIPHTTPDNSUDPICMPARPTLS

بروتوكول التحكم في الإرسال - موثوقية وموجه الاتصال :TCP

بروتوكول الإنترنت - توجيه الحزم وعنونة الشبكة :IP

بروتوكول نقل النص التشعبي - طلبات واستجابات الويب :HTTP

IP نظام أسماء النطاقات - ترجمة النطاقات إلى عناوين :DNS

فلاتر تحليل البروتوكولات

TCP تحليل مصافحة

tcp.flags.syn == 1 || tcp.flags.ack == 1

TCP كشف إعادة إرسال

tcp.analysis.retransmission

HTTP تحليل طلبات

"http.request.method == "GET

DNS تحليل استعلامات

dns.qry.type == 1 && dns.flags.response == 0

كشف أخطاء البروتوكول

tcp.analysis.flags || icmp.type == 3

تحليل سلوك البروتوكولات

HTTP و DNS زمن الاستجابة: قياس زمن استجابة

HTTP الضغط: تحليل استخدام ضغط

TLS/SSL التشفير: تحليل اتصالات

UDP مقابل TCP الأداء: مقارنة أداء

مستوى إكمال التحليل: %80

مهمة عملية

قم بتحميل ملف التقاط شبكة :PCAP تحميل ملف

تطبيق الفلاتر: استخدم فلاتر البروتوكولات

تحليل الأداء: قارن أداء البروتوكولات المختلفة

تقرير النتائج: قم بإعداد تقرير بتحليل البروتوكولات



قضية عملية 4: استكشاف أخطاء الاتصال وتشخيصها
استخدام Wireshark لتشخيص مشاكل الاتصال وفقدان الحزم وإعادة الإرسال

أنواع مشاكل الاتصال الشائعة

انقطاع الاتصالتأخير الاستجابةإعادة الإرسالفقدان الحزم

ازدحام الشبكة

فقدان الحزم: حزم تصل متأخرة أو لا تصل على الإطلاق

إعادة الإرسال: إرسال نفس الحزمة مرة أخرى

تأخير الاستجابة: زمن استجابة أعلى من الطبيعي

انقطاع الاتصال: انقطاع مفاجئ في الاتصال

فلاتر تشخيص المشاكل

كشف إعادة الإرسال

tcp.analysis.retransmission

كشف فقدان الحزم

tcp.analysis.lost_segment

كشف التأخير

frame.time_delta > 0.1

TCP كشف أخطاء

tcp.analysis.flags

كشف الازدحام

tcp.window_size < 1000

أدوات التشخيص المتقدمة

تحليل أنماط حركة المرور :I/O رسوم

كاملة TCP متابعة التدفق: تحليل اتصالات

إحصائيات نقطة النهاية: تحديد الأجهزة النشطة

معلومات الخبير: تحديد المشاكل المحتملة

مستوى إكمال التشخيص: %70

مهمة عملية

قم بتحميل ملف التقاط شبكة به مشاكل :PCAP تحميل ملف

تشخيص المشاكل: استخدم الفلاتر لكشف المشاكل

تحليل الأداء: استخدم الأدوات لتحليل الأداء

تقرير النتائج: قم بإعداد تقرير بالتشخيص والحلول



قضية عملية 5: تحليل حركة المرور المشفرة
Wireshark وتحليل حركة المرور المشفرة باستخدام TLS/SSL تقنيات فك تشفير

بروتوكولات التشفير الشائعة

TLS 1.3TLS 1.2SSL 3.0HTTPSFTPSSSH

بروتوكولات تأمين طبقة النقل :TLS/SSL

المفاتيح: مفاتيح متناظرة وغير متناظرة

للتحقق من الهوية X.509 الشهادات: شهادات

عملية التفاوض على خوارزمية التشفير :TLS مصافحة

تقنيات فك التشفير

استخدام مفتاح الخادم الخاص

Edit → Preferences → Protocols → SSL → RSA Keys
list

ملف سجل مفاتيح الجلسة

SSLKEYLOGFILE=~/sslkeylogfile.log

لفك التشفير Wireshark إعداد

Edit → Preferences → Protocols → SSL → (Pre)-
Master-Secret log filename

فلتر حركة المرور المشفرة

ssl || tls

SSL متابعة تدفق

Analyze → Follow → SSL Stream

خطوات تحليل التشفير

SSLKEYLOGFILE إعداد البيئة: تكوين متغير البيئة

إعادة تشغيل المتصفح: إعادة تشغيل المتصفح بعد الإعداد

Wireshark بدء الالتقاط: بدء التقاط الحزم في

تحليل الجلسات: عرض البيانات بعد فك التشفير

مستوى إكمال التحليل: %85

مهمة عملية

SSLKEYLOGFILE إعداد البيئة: تكوين متغير البيئة

لاستخدام ملف السجل Wireshark تكوين :Wireshark إعداد

HTTPS التقاط الجلسات: التقاط حركة مرور

تحليل النتائج: تحليل البيانات بعد فك التشفير



قضية عملية 6: تحليل سلوك التطبيقات
استخدام Wireshark لتحليل حركة مرور التطبيقات وتحديد مشاكل الأداء والأخطاء

أنواع التطبيقات المشتركة

نقل الملفاتالبريد الإلكترونيقواعد البياناتتطبيقات الويب

بث الفيديوالدردشة

HTTP/HTTPS، REST APIs :تطبيقات الويب

MySQL، PostgreSQL، MongoDB :قواعد البيانات

SMTP، POP3، IMAP :البريد الإلكتروني

FTP، SFTP، SMB :نقل الملفات

فلاتر تحليل التطبيقات

HTTP تحليل حركة مرور

http.request.method == "GET" ||
"http.request.method == "POST

تحليل استعلامات قاعدة البيانات

mysql || postgres || tds

تحليل البريد الإلكتروني

smtp || pop || imap

تحليل نقل الملفات

ftp || sftp || smb

تحليل أداء التطبيق

tcp.time_delta > 0.1

تحليل مشاكل الأداء

زمن الاستجابة: قياس زمن استجابة التطبيق

الأخطاء: تحديد أخطاء التطبيق والشبكة

الضغط: تحليل استخدام ضغط البيانات

الاتصالات: تحليل عدد الاتصالات المتزامنة

مستوى إكمال التحليل: %75

مهمة عملية

قم بتحميل ملف التقاط شبكة :PCAP تحميل ملف

تطبيق الفلاتر: استخدم فلاتر التطبيقات

م زمن استجابة التطبيق تحليل الأداء: قسّ

تقرير النتائج: قم بإعداد تقرير بتحليل التطبيق



قضية عملية 7: تحليل الشبكات اللاسلكية
استخدام Wireshark لتحليل حركة مرور الشبكات اللاسلكية وكشف نقاط الضعف الأمنية

بروتوكولات الشبكات اللاسلكية

802.11WEPWPAWPA2WPA3WPS

802.11: معايير الشبكات اللاسلكية

WEP، WPA، WPA2، WPA3 :بروتوكولات التشفير

المحمي Wi-Fi إعداد :WPS

أنواع الحزم: إطارات التحكم، البيانات، الإدارة

فلاتر تحليل الشبكات اللاسلكية

802.11 فلتر حزم

wlan

WPA/WPA2 فلتر حزم

wlan.wpa || wlan.rsn

فلتر نقاط الوصول

wlan.fc.type_subtype == 0x08

Deauthentication فلتر هجمات

wlan.fc.type_subtype == 0x0c

فلتر إشارات الاكتشاف

wlan.fc.type_subtype == 0x04

كشف نقاط الضعف الأمنية

شبكات مفتوحة: كشف الشبكات غير المشفرة

كشف نقاط وصول مزيفة :Evil Twin هجمات

كشف محاولات قطع الاتصال :Deauth هجمات

WPS كشف نقاط الضعف في :WPS ثغرات

مستوى إكمال التحليل: %80

مهمة عملية

قم بتحميل ملف التقاط شبكة لاسلكية :PCAP تحميل ملف

تطبيق الفلاتر: استخدم فلاتر الشبكات اللاسلكية

كشف الثغرات: حدد نقاط الضعف الأمنية

تقرير النتائج: قم بإعداد تقرير بالتحليل والتوصيات



)VoIP( قضية عملية 8: تحليل حركة المرور الصوتية والفيديو
استخدام Wireshark لتحليل حركة مرور VoIP وتحديد مشاكل الجودة والأداء

الرئيسية VoIP بروتوكولات

SIPRTPRTCPH.323MGCPSkinny

بروتوكول بدء الجلسة - إدارة المكالمات :SIP

بروتوكول النقل في الوقت الفعلي - نقل الصوت/الفيديو :RTP

مراقبة الجودة - RTP بروتوكول التحكم في :RTCP

مجموعة بروتوكولات للمؤتمرات الصوتية والمرئية :H.323

VoIP فلاتر تحليل

SIP فلتر حزم

sip

RTP فلتر حزم

rtp

RTCP فلتر حزم

rtcp

SIP فلتر مكالمات

"sip.Method == "INVITE

RTP فلتر مشاكل

rtp.ssrc || rtp.seq || rtp.timestamp

VoIP تحليل جودة

متوسط رأي المستخدم - قياس جودة الصوت :MOS

زمن الاستجابة: قياس التأخير في نقل الصوت

الاهتزاز: قياس تباين زمن الوصول للحزم

فقدان الحزم: حساب نسبة الحزم المفقودة%

مستوى إكمال التحليل: %75

مهمة عملية

VoIP قم بتحميل ملف التقاط :PCAP تحميل ملف

RTP و SIP تطبيق الفلاتر: استخدم فلاتر

RTP تحليل الجودة: استخدم أدوات تحليل

تقرير النتائج: قم بإعداد تقرير بجودة الاتصال



قضية عملية 9: استخراج البيانات والملفات من حزم الشبكة
استخدام Wireshark لاستخراج الملفات والبيانات من حزم الشبكة وتحليلها

أنواع الملفات القابلة للاستخراج

أرشيفملفات وسائطملفات تنفيذيةمستنداتصور

ملفات ضارة

JPEG، PNG، GIF، SVG :الصور

PDF، DOCX، XLSX، PPTX :المستندات

EXE، DLL، APK :الملفات التنفيذية

ZIP، RAR، TAR، 7z :الأرشيف

أدوات استخراج الملفات

HTTP استخراج كائنات

...File → Export Objects → HTTP

SMB استخراج ملفات

...File → Export Objects → SMB

استخراج مرفقات البريد

...File → Export Objects → IMAP

فلتر الملفات المستخرجة

"http.content_type contains "image

استخراج البيانات الثنائية

...File → Export Packet Dissections → As CSV

تقنيات تحليل الملفات المستخرجة

MD5/SHA التحقق من سلامة الملف: حساب تجزئة

كشف البرامج الضارة: فحص الملفات باستخدام مكافحة
الفيروسات

التحليل الثنائي: فحص محتوى الملفات الثنائية

تحليل البيانات الوصفية: استخراج معلومات التعريف

مستوى إكمال التحليل: %85

مهمة عملية

قم بتحميل ملف التقاط شبكة :PCAP تحميل ملف

تطبيق الفلاتر: استخدم فلاتر لتحديد الملفات

استخراج الملفات: استخدم أدوات الاستخراج

تحليل النتائج: قم بتحليل الملفات المستخرجة



قضية عملية 10: تحقيق أمني متقدم
استخدام Wireshark في التحقيقات الأمنية المتقدمة وكشف التهديدات المعقدة وتحليل الهجمات المستمرة

أنواع التهديدات الأمنية المتقدمة

APTاختراق البياناتهجمات التصيدبرامج فديةهجمات صفرية

DDoS هجمات

التهديدات المستمرة المتقدمة :APT

هجمات صفرية: استغلال ثغرات غير معروفة

برامج فدية: تشفير الملفات وطلب فدية

هجمات التصيد: انتحال هوية موثوقة

فلاتر التحقيق الأمني

كشف حركة المرور المشبوهة

frame.time_delta < 0.01 && frame.len > 1000

كشف محاولات الاتصال المشبوهة

tcp.flags.syn == 1 && tcp.flags.ack == 0

كشف أنشطة البرامج الضارة

"dns.qry.name matches "(malicious|suspicious)

كشف تسريب البيانات

http contains "password" || http contains

""credit_card

كشف الاتصالات غير المعتادة

ip.dst == 0.0.0.0/0 && tcp.port > 10000

تقنيات التحليل المتقدمة

تحليل السلوك: تحديد أنماط السلوك غير المعتادة

ًتحليل الارتباطات: ربط الأحداث المختلفة معا

تحليل البصمات: تحديد بصمات الهجمات المعروفة

التحليل الزمني: تحليل تسلسل الأحداث الزمني

مستوى إكمال التحقيق: %90

مهمة عملية

قم بتحميل ملف التقاط شبكة بهجوم معقد :PCAP تحميل ملف

تطبيق الفلاتر: استخدم فلاتر التحقيق الأمني

تحليل الهجوم: حدد نوع الهجوم وأساليبه

تقرير التحقيق: قم بإعداد تقرير تحقيق أمني شامل


